Outage - ArmorPoint Platform Service Disruption

Major incident Portal (US) API Mobile App Web
2026-06-10 09:30 MST · 1 hour, 41 minutes

Updates

Resolved

As of 11:00 AM MST on June 10, all affected ArmorPoint platform services have been fully restored, including data ingestion and platform access. Queued agent data is processing and systems are operating normally. A root cause analysis will be performed. Customers and partners can request the report by submitting a support ticket, and it will be provided as it becomes available.

June 10, 2026 · 11:00 MST
Update

Status Update — 10:20 AM MST, June 10

As of 10:20 AM MST on June 10, access to the ArmorPoint platform has been restored and data ingestion is flowing. As queued agent data processes, you may see temporary latency or intermittent performance. Our team is monitoring the service restoration and will provide additional updates as they are available.

June 10, 2026 · 10:20 MST
Investigating

At 9:30 PM MST on June 9, we identified a network and host infrastructure issue affecting the ArmorPoint platform. Platform services, including data ingestion, are currently unavailable. Data from agents is queuing and will process automatically once services are restored, which may cause temporary latency during recovery.

For clients with endpoint detection and response (EDR) services through ArmorPoint, those agents continue to collect, and our SOC analysts are actively monitoring and working alerts directly from the EDR platforms. Endpoint detection and response coverage for those environments is uninterrupted.

Our team is working to resolve the issue. 

June 10, 2026 · 09:42 MST

← Back